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Using Auto-numbering

This tutorial will teach you the practical use of the Auto-numbering feature in
Mellel. The tutorial will use the default numbering setups that come with Mellel
without modifying them. The first part of the tutorial will teach you how to use
Auto-numbers to format a book. The second part will teach you how to use Auto-
numbering with a legal-style document.

Auto-numbering a book

To accomplish this part of the tutorial you need basic knowledge of word
processing in general and some interest in learning how to create Auto-numbering
and a Table of Contents for a book.

1 Create a new document and save it with whatever name you like. We called
ours “Delenit et ea vulputate”.

2 Fill the document with 30 pages of gibberish. We've used the wonderful utility
MacLorem 2.0 (http://judebear.daveward.net/MacLorem/index.html) to create
text in pseudo-Latin. You can use this application, create your own gibberish or
use a more meaningful text—it’s up to you. If you chose to use Gibberish, you
should turn off Spelling to avoid painting your document in red.

3 Apply a style to the entire document. Regular will do.
4 Open the Auto-numbering palette and press the Edit Numbering flows button.
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Figure 1: The Auto-numbering palette
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5 From the Selected setups pop-up menu, select Book. Press OK. You've just
selected the Book Auto-numbering setup to use with your document—but the
document hasn’t changed at all. Don’t worry—it isn’t supposed to change yet.

6 Select the first few words in the document (or, enter three words of your own)
and choose Edit > Copy. Those words will serve as your first heading.

7 Press the Return key to move the text after the first words to the next line, and
select the words again.

8 With the words still selected, select Part from the list in the Auto-numbering
palette and press the Insert Auto-number button. Alternately, you can double-
click Part in the list.
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Figure 2: Inserting a numbering flow

9 IntheTitle dialogue box, choose Edit > Paste and press OK.

Title

Title: Delenit et ea vulputate|

-.__' Cancel '__,. ( OK )

Figure 3: The Title dialogue box

10 The title text you've entered should now appear over a light grey background at
the top of the page. If you do not see a background colour, open the Show
menu and select Auto-numbers. When this option is checked, Auto-numbers
will appear with a background in the document, but will be printed without it.
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Delenit et ea vulputate

velit feugait. Duis iusto esse lobortis nulla veniam consectetuer exerci

Figure 4: The title in the text

11 What you just did is to mark where a top level heading (like a part or even the
book title) starts. Now it’s time to add a chapter heading. Repeat steps 5-9, but
now choose another section of text (which can be the one immediately after
the main heading) and use the Chapter numbering flow. The result should look
like the following:

Delenit et ea vulputate

Duis iusto esse lobortis

In tation sciurus vulputate suscipit vel elit nulla duis consequatvel ea

Figure 5: After adding a chapter title

12 Now it’s time to add some more Auto-numbers into the text. Repeat steps 5-9
with the numbering flows Section and Sub-Section throughout the document.

13 What you just did seems a bit abstract so perhaps it is time to create a Table of
Contents that will clarify things. Move to the beginning of the document.

14 Choose Insert > Table of Contents. Press the Page Up key to move back to the
beginning of the document and examine the Table of Contents created based
on the Auto-numbers in the document. The Table of Contents should look
something like the following:
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Figure 6: The table of contents

Now that you've toiled so hard to create the Table of Contents, delete it. We
have one more thing to do before we can create the final Table of Contents.

Go to the first page in the document and open the Page palette.
Check the Header checkbox in the Page palette and click inside the header.

In the Auto-numbering palette, double-click (or select and press the Insert
Auto-number button) Chapter in the list of numbering flows.

A small title will appear in the header. This small title is called a Mention. If you
examine it closely, you will see that the text of the Mention corresponds to the
first chapter title.

Now go back to the Page palette and change the value for the Header height to

0.5 inch. You can do that by entering “0.5 in” in the header height text area.
When you're done, press the Return key.
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Figure 7: Entering the Header height value

The header should now look similar to the following:

Duis iusto esse lobortis

Delenit et ea vulputate

Duis iusto esse lobortis

Figure 8: Creating a mention

21 Go back to the page palette and press the button "Apply to range". A dialogue
box will appear: press Apply. You have now applied the header to the rest of the
document.

22 Scroll down the document. You will see that the title in the header changes
dynamically when a new chapter begins. This will also clarify why it wasn't a
good idea to generate the Table of Contents earlier: now that we have changed
the header, the position of the various headings in the document have also
slightly changed.

23 To finalise the document, repeat steps 13-14 to re-generate the Table of
Contents.




. Mellel Guide e Using Auto-numbering

24 But, just a minute—something went wrong! Look at what happened to the
header on page one:
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Figure 9: The wrong header

The problem here occurred because the Mention refers to the Chapter
numbering flow, whereas at the beginning of the document—where you've
created the Table of Contents—there is no Chapter numbering flow to refer to!
This obviously must be fixed. Scroll down the document to see on which page
the Table of Contents ends. In my case, that is page 2.

25 In the Page palette, uncheck Header to hide it. Now, the ugly header will
disappear and will make the page look neater.

26 In the Page palette, click Apply to range and enter 1 to 2 as the page range.

Apply page attributes

From Page: 1 to Page: 2

-.,; Cancel ';_. ( Applv:‘)

Figure 10: Page range to apply the change

26 Press Apply and examine the document. Now everything looks just right.
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Auto-numbering a legal document

As a sample text for applying auto-numbering to a legal document, we have used
the first chapter of the German constitution, as it appears at the following address:
http://www.angelfire.com/mn2/reformclub/f/germanyconst.html. You do not have
to use this particular document, but as it is the one after which our legal numbering
setup was modeled, it may be helpful for following this tutorial. You can then, of
course, change any of the settings to fit your particular needs.

1 Open a new document, copy the first chapter of the German constitution, and
paste it into the document. Save the document with an appropriate name.

2 Apply a style to the entire document. Regular will do.
3 Open the Auto-numbering palette and press the Edit Numbering flows button.
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Figure 11: The Auto-numbering palette

4 From the Selected setups pop-up menu, select Legal-General and press OK.
You've just selected the Legal-General Auto-numbering setup to use with your
document. As you can seeg, the items in the Numbering flow list in the Auto-
numbering palette have changed:
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Figure 12: Changes in the Auto-numbering palette
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Select the words “Basic Rights” in the document and choose Edit > Copy to copy
them. After that, select the text “Chapter | Basic Rights”

With the text still selected, select Chapter from the list in the Auto-numbering
palette and press the Insert Auto-number button. Alternately, you can double-
click Chapter in the list.

In the Title dialogue box, choose Edit > Paste and press OK.

The title text you have entered should now appear over a light grey background
at the top of the page. If you do not see a background colour, open the Show
menu and select Auto-numbers. When this option is checked, Auto-numbers
will appear with a background in the document, but will be printed without it.

The result should look something like the following:

Chapter I
Basic Rights

Figure 13: Result after chapter insertion

On the next ling, select “Human Dignity” (the first article title) and choose Edit >
Copy to copy it.

to select the entire line and double-click Article in the Auto-numbering palette.
In the Title dialogue box, choose Edit > Paste to paste the text you've copied.

Move to the next line and copy the words “Human dignity is inviolable”. This text
will serve as the title for the section. It will not be displayed in the text, but, as
you will see later on, it will be included in the Table of Contents.

Select the text“(1) " at the beginning of section 1. Double-click Section in the
Auto-numbering palette and paste the text that you copied earlier for the title.

Chapter |
Basic Rights

Article 1 [Human Dignity]

(1) Human dignity is inviolable. To respect and protect it is the duty of all

state authority.
T —

Figure 14: Results after step 10
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13 From now on, most of the work you have to do is just simple entry of items. You
can make things easier by using the Find option in Mellel. Copy the “(1) ”from
one of the sections and choose Edit > Find > Use Selection for Find.

14 Press Cmd+G (Edit > Find > Find Next) to find the next instance of “(1) . When
Mellel finds and selects it, copy the first words of the section (to serve as title),
select“(1) “again and double-click Section in the Auto-numbering palette. Yes,
it's a tedious job, but...

15 You can satisfy yourself by doing just a sample and then jumping to Article 12
of the document. Here you can see an interesting case: Article 12 followed
immediately by Article 12a. Since the latter is clearly a sub-section, you should
use the Sub-Article numbering flow with it. The same rule should apply to a
sub-section (such as 1a).

16 Once the document is done and numbered, go to the first page, open the Page
palette, and check the Header option.

17 Place the insertion point within the header and double-click Chapter in the
Auto-numbering palette.

18 Back in the Page palette, set the height of the header to 0.5 inch. The result
should look something like the following:

Chapter | Basic Rights

Chapter |
Basic Rights

Article 1 [Human Dignity]

(1) Human dignity is inviolable. To respect and protect it is the duty of all
state authority.

(2} The German People therefore acknowledge inviolable and inalienable
human rights as the basis of every human community, of peace, and of
justice in the world.

{3} The following basic rights are binding on legislature, executive, and
judiciary as directly enforceable law.

Article 2 [Liberty]
T ————

Figure 15: The result so far

19 Now we're ready to generate the Table of Contents. Go to the end of the
document, place the insertion point there, and choose Insert > Table of Contents.
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Chapter T Basic Rights . |
Article 1 Human DUgnity .ot |
(1) [Human dignity is inviolable] o, l
{2} [inviolable and malienable human rghts]. e |
{3) [The following basic rights are binding on legislature] ..o l
Article 2 Liberty ... et e ememenen |

(1) [Everyone has the right to free development].. oo |
R ————

Figure 16: The generated table of contents

Note that the titles for sections appear inside square brackets, to denote the
fact that they are not the official titles, just your improvised titles to serve as a
guide to the section contents.
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